全球化和Rails 4:兼容性状态

Globalize and Rails 4: Compatibility status

In a my previous question (asked about 2 months ago) I was trying to upgrade Ruby on Rails from version 3.2.13 to 4.0.0, without success because the globalize3 ruby-gem compatibility. Today I'm trying again to do the upgrade, without success because the globalize3 ruby-gem compatibility.

I tried all possible solutions that I found on the web (even those that refer to the rails4 branch) but no one works for me: I get error outputs as-like those present in my previous question. However, as you can read here, it seems that someone (lucky, maybe) has solved the compatibility issue. I am not a "lucky" one and, since I aim to use features added by Rails 4 and still use globalize3, I would like to know if there is someone running Rails 4 and the globalize3 with success. If so, what did he / she made to make that?

What is the compatibility status between globalize3 and Rails 4?


Note: I also opened a issue at github.

I'm using it with rails 4 and have no issue.

In my Gemfile:

gem 'globalize3', github: 'svenfuchs/globalize3', branch: 'rails4'

Run bundle update instead of bundle install to resolve all dependencies again. Just lock gems that you don't want updated by indicating a version specifier as explained here http://bundler.io/v1.3/gemfile.html.

fatal: ambiguous argument 'rails4': unknown revision or path not in the working tree.
Since then I updated to gem 'globalize', '~> 4.0.0.alpha.2'